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ABSTRACT  

The application of a community strategic framework (CSF) (Scattoni, 

2018) requires simple and low-cost techniques. CSF is an approach 

communities can work with to identify the main characteristics of the 

problems they are facing and to help with making decisions about 

these problems. This article outlines the essential and immediately 

operational elements for applying STAN (STrategic ANalysis) 
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software. This develops from the “strategic choice” approach 

(Friend and Jessop, 1969) and, while computerised techniques have 

been developed, they have been found to have limitations and have 

been little-used (Friend and Hickling, 2005). Some applications have 

been attempted in the Italian context (Giangrande and Mortola, 

2005) but without a significant following. 

This paper aims to show how a computerised technique called STAN, 

which developed about ten years ago, can be used for constructing 

and managing a CSF. Indeed, this technique has characteristics that 

are well suited to community use because, in particular, it requires 

only basic knowledge of computer science, which we can assume to 

be present in many small groups of people.  

 

An important additional condition is the STAN software’s free 

license, available as open source software. The method’s versatility 

makes it possible to integrate it properly where the formation of the 

CSF is oriented to cooperation, information exchange, or possible 

conflict comparison between various stakeholders, as well as 

decision makers. 
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INTRODUCTION 

The article is formulated as follows. Previous attempts to use STAN 

software will be analysed. It is particularly important to assess the 

potential, as well as the limits, which has not permitted the 

development in the past. Thereafter, this paper will evaluate the 

possible use of such a technique in a strategic choice approach. The 

paper then focuses on the steps required for using STAN in a CSF 

and presents specific steps for constructing the CSF, considering the 

assumed minimum conditions. The identification of the actors, 

perception of the problems and of the possible alternative courses of 

action are then analysed to solve the perceived problems. The 

identification of possible conflicts then outlines negotiating strategies.  

 

The paper then offers a brief review of the applications so far 

carried out in experimental teaching exercises and proposes the 

possibility of developing a basic guide for using STAN software. 

Finally, the conclusions focus on the possible technical 

developments in relation to CSF. 

 

STATE OF THE ART 

STRATEGIC CHOICE 

The method refers to the strategic choice approach for urban 

planning. Friend and Jessop summarise the essential features in the 

fifth chapter of their book, which was published in 1969 (Friend, 

Jessop, 1969). 
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The approach is innovative, looking at planning as a continuous 

process of interaction and dialogue between a system of government 

and a community system. 

 

Often, the demands of the community system are confused and 

unstructured and the government system has the responsibility to 

structure community demands and needs.  The authors describe this 

process through progressively complex diagrams and a particularly 

important contribution is the classification of uncertainties 

characterising public decision-making processes in general and those 

of planning in particular. They identify three sources of uncertainty. 

The first uncertainty is related to the knowledge of the environment 

(UE, Uncertainties related to the Environment), with reference to the 

difficulties of urban analysis, particularly in relation to the forecasting 

tools. 

 

Setting out a problem and the possible options to solve it is called 

“decision area”. The combination of the possible options allows for a 

whole range of possible general solutions to be identified.   

 

The alternatives may, in fact, emerge from the study of the technical 

system of government, or from the knowledge expressed by the 

community. 
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The various options are evaluated from different points of views. 

Each stakeholder can express different preferences. Further, each 

option can have different consequences in relation to objective 

parameters as environmental impacts, costs, etc.  

 

The decision process does not necessarily occur according to a strict 

sequence. Often, it is done through progressive mutual adjustments, 

which may also go through community participation, organised in 

various ways. 

 

STRATEGIC CHOICE FOR CSF 

In Italy, the strategic choice approach has not found many 

applications. In 1974, Baldeschi and Scattoni provided the first 

translation in Chapter 5 “The nature of planning” of Friend and 

Jessop’s book (1969). The following year, Balbo (1975) introduced 

the AIDA technique.  Much later, Giangrande and Mortola (2012) 

made the first operational test. Only in Grosseto’s structure plan does 

the strategic choice approach find application. The Grosseto Structure 

Plan remains the only large-scale plan using strategic choice 

(Scattoni, 2007). Looking at these few theoretical and practical 

experiences, it is necessary to evaluate how the approach can meet 

the characteristics of a CSF. In fact, in CSF, common knowledge 

prevails over expert knowledge. In this paper, we try to demonstrate 

that the approach is suitable for this requirement if it is driven by a 

simple and understandable sequence and with the aid of an equally 

simple, computerised procedure. The operations for the framework’s 
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construction are strategic choices made from progressively 

identifying problems. The definition of the options proceeds from the 

simplest, which implies no action, to the complex. 

 

For each problem, the “no action” option needs to be considered 

(keeping the existing situation, i.e., the status quo) and a generic 

change statement then develops over time with increasingly specific 

options. The technological support can be managed by a member of 

the group with only minimal computer knowledge. The minimal 

expertise required involves simple operations, such as software 

installation and management. 

 

PREVIOUS EXPERIENCE 

In this paragraph, the discussion is about the STAN software as the 

support for strategic choice. Such software was developed in two 

phases.  

 

The first phase takes shape in the 70s at Newcastle University by 

Openshaw and Whitehead (1975). They developed software called 

DOT (Decision Optimising Technique). They derived DOT from the 

AIDA (analysis of interconnected decision areas) approach developed 

at IOR (Faludi and Mastrop, 1982). The second phase concerns 

reusing some of those experiences to finally outline a simple and 

intuitive tool: STAN software. It requires limited technical skills and 

is easily accessible even in poorly structured or spontaneous groups, 
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with limited resources, but which are interested in building a 

community strategic framework.  

 

The same IOR school later developed the STRAD software, which is 

limited to the treatment of subsets of the decision-making framework 

identified with the strategic choice method.  

 

Above all, STRAD helps to frame the decision-making process 

through workshops in which various stakeholders participate. 

However, in this method, technical expertise is essential (Friend J.K., 

Hickling A., 2012, chap.10). 

 

Openshaw and Whitehead’s abandonment of the DOT software’s 

development from 1985 had different technical reasons, mainly 

concerning the computer limits at that time. Openshaw and 

Whitehead investigated the interactive use of DOT when adequate 

computer power was available at the time only at a few universities. 

Only in their last contribution did Openshaw and Whitehead (1985) 

sense the importance of the personal computer but obstacles 

concerning easy use in practice still remained at that time. 
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THE NEW PHASE: STAN DEVELOPMENT 

 

Picture 1 - STAN initial banner 

The Grosseto Structure Plan’s preparation (2000-2006) provided the 

environment for developing a technique to support the strategic 

choice approach, operated by a group of planning consultants from 

Sapienza Rome University. The main inspiration for STAN 

originated from this work, with a research group comprising a 

planner, an expert in operational research, and a computer expert.  

Unfortunately, STAN was not ready for the Grosseto Structure Plan 

but it later found several applications, mainly in university teaching. 

Its official presentation took place in 2005 in a seminar taken at the 

Department of Urban and Regional Planning. All of this has created a 

research group formed mainly by urban planners and computer and 

operational research experts. 

 

The STAN software, mainly based on linear programming 0/1 

elements (Ricca and Scattoni, 2008), comprises  methods and models 
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of operations research suitably designed to provide a decision support 

tool, in line with the principles and processes that characterise the 

stages of strategic decision making. Thus, it is developed from the 

work of Openshaw and Whitehead and exploits the possibilities of 

computers available today on the market, in addition to exploiting the 

advances that have been made in software. Through the tools offered 

by the Java programming environment, a graphical interface has been 

developed that allows even complex strategic frameworks to be 

managed. 

 

The user interface allows the integer linear programming models to 

be set up by simply selecting them from a subset of possible methods 

including those available. The following are the criteria (Ricca and 

Scattoni, 2008) used for developing and setting up STAN software: 

1. debate: STAN software allows the stakeholders involved in 

the planning process to participate interactively in developing 

the strategic framework; 

2. flexibility:  the strategic framework can be easily modified 

according to the dynamics of the decision process; 

3. traceability: the strategic framework can be commented on in 

its entirety through the placement of text, which allows for 

changes to the strategic framework over time to be described 

in order to be able to reconstruct the main transformations; 

4. low cost: STAN is an open-source software under the GNU 

license and is, therefore, freely downloadable, testable in the 

source code, and possibly modifiable. The users only need a 
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personal computer and possibly a video projector for use 

during sessions. STAN explores a large number of solutions 

through the aid of mathematical and statistical tools. The role 

of the software is not to replace the decision maker but to 

allow the actors of a given context, based on debate, to 

explore the alternatives in the decision-making process. It can 

help with assessing the effects of preferred options and 

provide the traceability of the decision-making process.  

 

STAN, thus, assists the decision makers, offering a strategic 

choice environment, looking at: 

 decision areas, which represent the structure of the problem; 

 options, the alternatives of choice for every possible decision 

area; 

 criteria to evaluate the different alternatives; 

 the relationship between the options of the various decision 

areas. 

 

In April 2014, the research group released version 2.0, incorporating 

software updates and developing a function to export the CSF in a 

format compatible with MediaWiki. Such a function provides the 

possibility of interaction between a decision wiki database (Scattoni, 

2018) and STAN software. A worked application is in the appendix. 
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CONCLUDING REMARKS 

The STAN technique looks to play a key role for the CSF as 

imagined by Scattoni (2018). It is economically sustainable for any 

voluntary group, even if they are small. The software is available for 

free, the necessary technical knowledge is minimal, and it can be 

assumed that, within each group, there are members able to manage 

STAN appropriately. Defining decision areas through meetings and 

opinion exchange, either live or through the web, is an easy task. 

Once started, the process of defining options and actors’ positions 

should follow without significant difficulty. In this respect, the link 

with knowledge organised according to a classical strategic choice 

approach is important. A wiki database based on the strategic choice 

approach can further facilitate the use of STAN. Decision areas, 

options, value judgements by stakeholders (that of the group, as well 

as those deduced from other actors), and interconnections among 

decision areas can easily feed into a STAN exercise.  

 

Consequently, the CSF can also be built through easy steps in a group 

meeting, using basic equipment like a computer connected to a 

projector. 

 

Using STAN allows for the summary of the CSF on a single page 

where all the essential elements can be read. On the other hand, the 

page elements can be described through text, even entered during the 

meeting with synthetic notes and, if necessary, refined later. Such a 

feature is particularly important for preparing reports to support the 
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group in different situations, such as the public participation exercises 

launched by the “government”. Further, the ability to export to an 

Excel format can simplify the analysis of a CSF. 

 

On the other hand, there are obstacles to be considered for full 

implementation of the technique in a small group context. The initial 

absence of experience may be a significant obstacle. Until now, the 

implemented experiences occurred in a university teaching 

environment. In a real-world situation, it is almost certain that a 

proposal from one or more members of the group can encounter 

scepticism by others. Regardless that the technique is simple to 

understand, in situations of conflict between community and 

government, use of STAN may appear an alien and ineffective 

exercise. It could appear unable to help in managing decision making 

where impairment is evident, especially in terms of access to sensitive 

information. Of course, the prior construction of a wiki related to the 

decision-making process can help to dissolve scepticism. It is, 

therefore, important to make clear that the technique is not a black 

box for producing solutions but only a means to order them in an 

operational way for self-organised groups. 

 

Future research on STAN can develop according to two main 

directions: software and empirical work. As far as software is 

concerned, different research activities must be implemented. It is 

necessary to provide regular updates, especially in relation to Java 

updates and releases. As a matter of fact, Java guarantees operability 
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with most operating systems: Linux, Windows, and Mac. The 

transition from 1.0 to the current 2.0 version of STAN is needed to 

ensure the software is used with new releases of Java. Also, 

implemented functions of the exported CSF need to be in a 

compatible format with the MediaWiki software in order to give users 

the opportunity to interact with both systems.  

 

More importantly, the effectiveness of STAN can greatly benefit 

from a facilitated interrelationship with the information base on the 

wiki. For non-technically-oriented groups, it is important to simply 

provide inputs in terms of decision areas, options, different actors 

involved and related value judgements, as well as technical criteria 

and functional relationships.  

 

A last but not least aspect is that of collecting experience from small 

groups using the software. Such documentation would be of great 

importance to work on possible improvements. For such a purpose, a 

platform linking different experiences could be of value for research. 

APPENDIX - OPERATING PROCEDURE 

The appendix is designed to show an example of dealing with a 

decision area starting from a CSF using the latest version of the 

STAN software (http://stan.sourceforge.net/). 

 

The diagram below is the basis for identifying the elements that will 

make up a decision area, so called because of the models and the 

http://stan.sourceforge.net/
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methods shown in the previous paragraph. The set of decision areas 

and their contents will form the CSF. 

Box n.1 shows the structure of a decision area. 

TITLE OF THE DECISION AREA 

 

PROBLEM 

Description of the problem. 

 

OPTIONS 

Possible options for a resolution to the problem. 

 

ACTORS 

Main actors involved in the problem. 

 

RELATED AREAS 

Decision areas related and, therefore, mutually influenced. 

 

LEARN ABOUT 

Documents to learn about and resources to support the knowledge of 

the problem. 

The STAN has a common type menu. In the bar at the top of the 

window, you can find File. With left-click, it will open a drop-down 

menu through which you can make basic operations on CSF. 
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With left-click on File-> New, you can create an empty CSF while by 

left-clicking on File-> Open you can open an existing CSF. Some 

example scenarios are available in the examples directory within the 

STAN software folder. 

 

 

Picture 2 - Left-click on File 

 

Picture 3 - New empty CSF 
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Once opened or created, you can save the CSF by left-clicking on 

File-> Save or File-> Save as. The difference between the two 

operations is that the first stores the same file from which you opened 

the CSF while the second allows you to specify a new file on which 

to save the scenario. It is possible to open multiple scenarios and call 

them from the Window menu item, which can be found to the right of 

the File menu. You can close the single CSF by left-clicking on File-

> Close. 

 

The software also enables the printing of a CSF report. This report is 

visible in preview mode by left-clicking on File-> Print Preview and 

can be forwarded to the printer by left-clicking on File-> Print. 

 

To exit the program, left-click on File-> Quit. 

 

The insertion of the data is done through a pop-up context menu, 

which is able to display the type of operation permitted depending on 

the row and column in which the pointer is located at the moment in 

which the operator invokes the menu with the right-click. 
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Picture 4 - right-click context menu 

The operations that allow the context menu are as follows: 

 add / edit / delete a decision area with the possibility of 

inserting text that describes the problem to be treated; 

 add / edit / delete an option with the possibility of inserting 

text that describes the proposed solution; 

 add / edit / delete an EVO column going to identify the 

actors/stakeholders or any other constraint criteria; 

 add / edit / delete the mutual condition of influence between 

the options of the same area of the decision or from the 

options of the other decision areas. 

 

The documents collected in support of knowledge cannot be inserted 

directly into STAN software. However, in the case of a publication of 

the CSF on a wiki-type website, these documents will complement 

the decision area as an integral part of it. 
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The wiki-type website can also be used for storing a state of the CSF 

at a given moment in time. Similarly, the wiki-type website, thanks to 

the functions of discussion and participation, can be a source of items 

to complete or update the CSF on STAN software. 

Once you have entered all the data, we will have the CSF to be 

analysed in tabular form. In the first column, we will find lines of text 

containing the options, the latter grouped by decision areas that may 

contain descriptions or comments entered into the correct field via the 

context menu, the same thing is true of the decision areas that are 

freely open to comments and sortable freely by the right-click menu. 

 

In the second column, ordered from left to right, you can find 

incompatibilities and stakeholders. Usually, among the first columns, 

you can find mutual exclusions between options incompatible with 

each other and in the columns to follow, we can identify the 

stakeholders. Alternatively, other constraint criteria can be inserted. 

Each constraint can be set either as a target function for maximum 

thresholds of values, as a target function for minimum value 

thresholds, or as an objective function between a pair of minimum 

and maximum values. 

 

For each stakeholder, there is an evaluation column expressed in a 

choice scale (e.g. from 1 to 10) that must be maintained homogeneous 

for all the evaluations. 
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In addition to subjective judgments for each related stakeholder 

STAN may consider continuous measures such as those related to 

costs, environment, etc. 

 

STAN allows for moving the original columns and lines by the user.  

 

Therefore the software facilitates the planning process during the 

various phases of comparisons and negotiations.  

 

ACHIEVED RESULTS 

This paragraph looks at an example in order to clarify the way STAN 

functions.  

 

It is from a work carried out in 2006, taken from exercises in final 

dissertations (Opolka, 2006). The thesis tests the method (strategic 

choice approach and STAN) in an unplanned Rome neighbourhood. 

 

The thesis was built through the local organisations helped by the 

formulations of CSF. It identifies decision areas, options for each one, 

the stakeholders involved, and the interrelations between decision 

areas. 
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Picture 5 - Initial CSF with three decision areas 

Box n.1 shows the structure of a specific decision area. 

DECISION AREA – SEWERAGE NETWORK 

PROBLEMS 

Increasingly reported sewage spills that resulted in extensive damage 

to homes.  

The causes were: 

- Defective sewerage network 

- Lack of maintenance; 

- Many of the old drainage canals were closed. 

OPTIONS 

1. Maintain the current situation; 

2. Strengthening of the existing sewerage network,  

3. New sewerage network; 

4. Scheduled maintenance of the sewerage network; 

5. Scheduled maintenance of the sewerage network plus 

strengthening of the existing sewerage network; 
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6. New sewerage network plus strengthening of the existing 

sewerage network. 

ACTORS 

- Main municipality of Rome; 

- Local municipality district; 

- Committee of district; 

- Small owners of vacant lots. 

RELATED AREAS 

- Local roads 

FURTHER ANALYSIS 

Documents to learn about and resources to support the knowledge of 

the problem. 

Box n.2 shows the evaluation provided by four main stakeholders. 

The scale is 1 to 5, where 1 is very negative and 5 is very positive for 

interviewed stakeholders. 

 

Stakeholders 

/ 

Options 

 

Main 

municipality 

of Rome 

 

Local 

municipality 

district 

 

Committee  

of the 

district 

 

Small 

owners  

vacant 

lots 

1. Maintain the 

current 

situation 

1 2 1 1 

2. Strengthening 3 4 2 2 
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of the existing 

sewerage 

network 

3. New sewerage 

network 

2 3 4 4 

4. Scheduled 

maintenance 

of the 

sewerage 

network 

3 4 4 4 

5. Scheduled 

maintenance 

of the 

sewerage 

network plus 

strengthening 

of the existing 

sewerage 

network 

3 5 4 4 

6. New sewerage 

network plus 

strengthening 

of the existing 

sewerage 

network 

3 3 5 4 



 

 

 

 

 

 

Lombardi – STAN: a software for a Community Strategic Framework 

 

 

IJPP – Italian Journal of Planning Practice  Vol. VIII, issue 1 - 2018 

 

 

83 

 

 

Picture 6 - An example of elaboration that displays the preferred 

solutions for the "Main municipality of Rome" stakeholder 

 

Picture 7 - An example of elaboration that displays the preferred 

solutions for the "Local municipality district" stakeholder 

 
Picture 8 - An example of elaboration that displays the preferred 

solutions for the "Commitee of district" stakeholder 
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Picture 9 - An example of elaboration that displays the preferred 

solutions for the "Small owners of vacant lots" stakeholder 

More recently in a final dissertation (Lombardi, 2018), the method 

was tested in the context of the urban renewal of the main 

archaeological area of Rome. The thesis ends with a detailed 

evaluation of the results regarding stakeholders’ preferences. 
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